Q&A - Question Create PixelStore in PostgreSQL Question NatW asked on March 22, 2018, keyword: Viewer / Editor Hello, I am trying to create a new PixelStore in a PostgreSQL (v. 9.5) database running as localhost on Win 7. I am using TatukEditor 4.59.0.12869. I created a pix_test_3.ttkps file with the text in the code snippet below. I am connecting to the database via the PostgreSQL ODBC Driver(UNICODE). I am able to load a PostGIS vector layer from the database using a .ttkls file and have no issues reading it, although I've not been able to make edits. In TatukGIS Editor, I load a small aerial image. Then I go to File --> Export To Image, select the pix_test_3.ttkps file, allow overwrite, set to document to save file space while testing, and then proceed. After it starts running, I get an error window stating 'Error on export image 0180 Unexpected error upon drawing "" layer. Exception message : Operation is not allowed in this context' In the database, I have a new table titled "pix_test_3". It contains a single row, with nlevel=1, nrow=0, ncol=0 and cell=null. There is also an entry in the ttkgispixelstore2 table that appears to have appropriate x and y min and max and projection. Interestingly, the name in this table includes the schema ("public.PIX_TEST_3"), while tests I tried before upgrading to the most recent stable version of TatukEditor do not include the schema ("PIX_TEST"). I have also tried a "pix_test_4" to see if the error was due to mixed upper/lower case, but got the same error. Using the 32-bit Editor gave an error with the ODBC driver, and changing layer in the .ttkps file to "public.pix_test_5" gave a cross-database references error. Do you know what I am missing? [TatukGIS Layer] ADO=Provider=MSDASQL.1;Persist Security Info=False;User ID=postgres;Data Source=scratch_pg;Initial Catalog=scratch Dialect=POSTGRESQL Layer=PIX_TEST_3 Storage=PixelStore2 Answers Tomasz Kosinski (TatukGIS) replied March 20, 2018 It is beyond Q&A scope. I converted it to support ticket. We will contact you directly. NatW replied March 21, 2018 For future users searching Q&A, the support team will be testing the ODBC connection, but provided the following ttkps text that uses libpq (rather than ODBC) and it worked well in TatukGIS Editor. This connection in a ttkls also allowed edits to be made in PostGIS. According to Support, you may need to copy libpq dlls (5 files) into the Editor directory, although I did not need to. [TatukGIS Layer] Storage=PixelStore2 Layer=PIX_TEST_3;public DIALECT=POSTGRESQL Libpq=host=localhost port=5432 dbname=scratch_pg user=postgres password=***** ENGINEOPTIONS=16 If you would like to answer the question please Sign In. * * Stay signed in on this computer Please review our recent Privacy Policy.If you have any questions or requests, please contact us. Forgotten password Rules The Questions and Answers (Q & A) is intended to provide a means of communication between TatukGIS customers. Licensed users (with active maintenance play) of TatukGIS products may contribute to the Q & A content. Read-only access is available to anyone. Keep the content positive and professional. Be courteous to others by posting information when a question or issue asked on the Q & A is answered or resolved by other means (such as with help from TatukGIS technical support). Offer others at least a hint how the posted question was answered or the issue was resolved. The Q & A is not a replacement for TatukGIS technical support. TatukGIS team may or may not regularly follow or contribute content.